nomunomu0504.blog

技術メモ / 車 / 音楽 / 雑記 / etc...

Ruby_on_Railsを勉強する

更新日

この記事は随時更新します。

現在 08/14 に更新

Ruby on Railsをやる

とりあえず、VMware上にUbuntu18.04 LTSをインストールして、Railsが使えるようになったところまでした。

エラー対策

rails sに失敗する(08/05追記)

`rescue in block (2 levels) in require': There was an error while trying to load the gem 'uglifier'. (Bundler::GemRequireError)

Gemfileを編集する

以下を追加してbundle installします

gem 'therubyracer', platforms: :ruby

mini_racer

どうもtherubyracerは使われなくなった模様?

Please replace therubyracer with mini_racer in your Gemfile. こんなエラーが出てきました。つまりは、therubyracerを使わずにmini_racerを使えってことらしい

結構前からじゃん...。知らなかったわ。

github.com

ライブラリを入れていく

easy_settings

gem 'easy_settings'

YAMLファイルで設定ファイルを記述することができます。 qiita.com

devise

gem 'devise'

ユーザ登録、confirmリンク、パスワードリセット等、認証関係を簡単に行うことができるGemです。 qiita.com

bootstrap
gem 'bootstrap'
gem 'jquery-rails'

これは有名ですね。デザインの知識がなくてもデザインができる(ように感じる)ライブラリです。 getbootstrap.com

railsでbootstrapを動かすようにするには、いくつか別のライブラリも導入する必要があります。 qiita.com

guard

gem 'guard-livereload', require: false

ファイルを更新すると自動的にブラウザが更新されて、IDEとブラウザを行き来する手間が省けます。 Google chromeでは、拡張機能を追加する必要があります。

rubyandrails.hatenablog.com

letter_opener
gem 'letter_opener'
gem 'letter_opener_web'

本登録メールやお知らせメールなど、メールを送る際にローカルで受信して内容を確認することができます。

qiita.com